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Alerts 

IP-6648 – Alerts Function – Printer Out of Paper Alert 

This function introduces the ability to configure an Alert that will be triggered when a printer runs out of paper. 

This is particularly useful in environments that contains Kiosks so that when the Kiosk printer runs out of paper, an 

Alert will be triggered. 

Alerts can be configured to write an event to an Alerts.log file and/or send an email notification. 

 

To configure and use this function, go to: 

Back Office > Setup > Global Options > Other Options > Alerts > Output from POS#. 

Ensure that the Output from POS# is configured so that it reflects a POS Terminal Number or Back Office Number on 

the network. 

Note that for alerts to be sent, the POS Terminal Number or Back Office Number entered in the Output from POS# 

must remain on during trade. If that terminal is switched off, alerts will not be sent. 

 

Also while in the Global Options > Other Options tab, ensure that the Email Settings have been configured if Email 

Notifications for Alerts are required. 

The Email Service can be set to either Idealpos Email or Custom. 

Idealpos Email will send Email Notifications using the Idealpos Email Service and no further Email Service configuration 

is necessary. 

Custom will enable your own Email Service to be configured and will require the entry of additional settings such as 

SMTP Outgoing Email Server, SMTP Username, SMTP Password, SMTP Port and Enable SSL/TLS Protocol. 
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To configure the Alert, go to: Back Office > Setup > Alerts > Add. 

Alert Description: Out of Paper 

If Function Type: Printer Out of Paper 

Quantity reaches: 1 in 1 Minutes 

POS Range: If required, enter a POS Range or a specific POS Terminal Number. 

If this function is being configured for a Kiosk, the Kiosk POS Terminal Number Range can be entered. 

 

Write to Alerts.log: Enable the checkbox if this alert needs to be written to the Alerts.log. 

Send Email to: Enable the checkbox and enter an email address to send the alert to if an email notification is required 

for this alert. 

 

Email/Log Message: The printer is out of paper! Please insert a new paper roll into printer: {PrinterName} 
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When the printer runs out of paper, an Alert will be triggered as per the Alert configuration. 

 

If Send Email to was enabled, an Email will be sent to the Email address configured. 

 

 
 

If the Alert.log option is enabled, the Alert will also be written to the Alert.log. 

Note that the Alert.log will only be created on the POS Terminal that was configured in Global Options > Other 

Options > Alerts > Output from POS#. 

The Alert.log is in the following folder path on the POS Terminal that was configured in the Output from POS#: 

 

C:\ProgramData\Idealpos Solutions\Idealpos\LOGS\Alerts.log 
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Automatic Sales Export 

IP-6781 – Automatic Sales Export – Sales Categories Totals Format 

This function introduces the ability to configure Automatic Sales Export – Sales Categories Totals Format to be 

exported daily at a set time or exported at a specific minute interval. 

 

The data that is exported using this format will appear similar to the example below: 

 

Company,SiteCode,SiteDescription,POSCode,POSDescription,SalesCategory,Quantity,NettEx,Tax,NettInc,Discounts,Gros

sInc 

9999,91,ABC Coffee Co,1,POS Terminal 1,ACCESSORIES,2.0000,40.81,4.09,44.90,0.00,44.90 

9999,91,ABC Coffee Co,1,POS Terminal 1,CONSUMABLES,1.0000,8.00,0.00,8.00,0.00,8.00 

9999,91,ABC Coffee Co,1,POS Terminal 1,DRINKS &amp; BEVERAGES,1.0000,4.82,0.48,5.30,0.00,5.30 

9999,91,ABC Coffee Co,1,POS Terminal 1,FOOD,6.0000,70.36,7.04,77.40,0.00,77.40 

9999,91,ABC Coffee Co,1,POS Terminal 1,ROASTED COFFEE,2.0000,59.50,0.00,59.50,0.00,59.50 

9999,91,ABC Coffee Co,1,POS Terminal 1,TEA,1.0000,4.27,0.43,4.70,0.00,4.70 

9999,91,ABC Coffee Co,1,POS Terminal 1,WET COFFEE,4.0000,20.09,2.01,22.10,0.00,22.10 
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To configure this format, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export. 

 

Configure the Automatic Export Settings as follows: 

Export Folder: Select a folder location where the data should be exported. 

Export Sales Format: Sales Categories Totals 

Sales From: All POS Terminals 

Export Daily at/Or every minutes: Enter the Daily Export Time if a single export is required daily, or enter a minute 

interval if an export is required every # minutes. 

 

 
 

The Sales Categories Totals will be exported to the Export Folder path as per the Export Interval (Export Daily at or 

every # minutes). 
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Additional Info: 

 

User-Defined Option to override POS Terminal Description 

If a different POS Terminal Description is required in the Exported Data (compared to the standard POS Terminal 

Description that’s configured in Back Office > Setup > POS Terminals), this can be set via a User-Defined Option. 

Go to: Back Office > Setup > POS Terminals > Select the POS Terminal > Modify > POS Settings > User-Defined 

Options. 

Create the following User-Defined Option: 

• Description: EXPORTPOSDESCRIPTION 

• Setting: Enter the desired POS Terminal Description. 

 

 
 

Company Code in Exported Data 

The Exported Data contains a Company field and the value used in the Company field is retrieved from Back Office > 

Setup > Global Options > General > Venue ID. 

If the Venue ID is not set, a default value of 9999 will be included in the Company field of the data that is exported. 
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Coupon Promotions 

IP-6785 – Coupon Promotions – Redeem External Coupons to specific Customer Types 

This function introduces the ability to restrict the redemption of External Coupons to specific Customer Types. 

To use this function, go to: Back Office > File > Sales > Promotions > Coupon Promotions. 

Select an existing Coupon and Modify or create a new Coupon via the “Add” button. 

 

In the Advanced tab of the Coupon, ensure that the External Coupon Linking has been configured with the External 

Coupon barcode details. 

The below is purely an example for the purposes of demonstrating this function. 
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In the “Promotion” tab of the Coupon, configure the Coupon Promo as required. 

When configuring the Coupon Promo, ensure that the “Customer Type” field has been populated with the Customer 

Type that this External Coupon is to be restricted to (Press the “>” button in the Customer Type field to select the 

required Customer Type to restrict the External Coupon to). 

 

 
 

Close the Coupon Promotions window and save the changes when prompted. 
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The External Coupon is now ready for use and will be restricted to the Customer Type that has been configured. 

 

Go to: POS Screen. 

Add items to the sale, then attempt to scan/enter the External Coupon barcode when a Customer from the Customer 

Type has not been added to the sale. 

Idealpos will display the following prompt (Invalid Customer for this Coupon!): 

 

 
 

  



    Update History 
Return to top 

Idealpos 9 Build 5 - Update History Page 11 of 59 

 

The External Coupon will only be accepted and applied when a Customer that’s linked to the Customer Type in 

Coupon Promotion is added to the sale. 

 

The below example shows the Customer added to the sale along with the Stock Items that are eligible for a discount 

and the External Coupon Promo Barcode being manually entered. 

 

 
 

After the ENTER key is pressed, the External Coupon is accepted into the sale and the Coupon Promo is applied. 
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EFTPOS 

IP-6663 – Oolio Pay – Option to separate Pinpad Surcharges from EFTPOS Totals 

This function introduces the ability to configure Idealpos to separate Pinpad Surcharges from EFTPOS Totals when 

using the Oolio Pay Global or Oolio Pay AUS/NZ. 

Prior to this change, EFTPOS Totals shown in Idealpos Reports and the Cash Declaration would be combined with the 

EFTPOS Surcharges when using Oolio Pay, and it wasn’t possible to separate EFTPOS Totals from the EFTPOS 

Surcharges. 

This functionality is configured by configuring a Tender as a Surcharge Tender, then assigning the Pinpad Surcharges 

to the Surcharge Tender. 

The Reports/Cash Declaration in Idealpos will then record and display surcharges against the Surcharge Tender. 

 

To configure this function, go to: Back Office > Setup > Function Descriptors. 

Locate the next unused Tender (unused Tenders are labelled as Tender #, where # will be the number of the Tender 

Function). 

Modify the unused Tender and set the Description as “EFTPOS Surcharge” (or enter your preferred description). 

The entered description will appear in Idealpos Reports and EFTPOS surcharges will be displayed against this tender. 

Save the change by pressing the “Save” button on the top-left corner of the Function Descriptors window. 
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Go to: Back Office > Setup > POS Terminals > Select a Terminal > Modify > EFTPOS Settings > EFTPOS Type: Oolio 

Pay Global or Oolio Pay AUS/NZ. 

In the Pinpad Surcharges dropdown box, select the newly configured EFTPOS Surcharge Tender. 

If the Pinpad Surcharges dropdown box is left as blank, the Pinpad Surcharges will be combined with the EFTPOS 

Totals. 

If the Pinpad Surcharges dropdown box is linked to a tender, the Pinpad Surcharges will be recorded against the 

selected tender. 

 

 
 

After making this change, close the POS Terminal settings and repeat the configuration for each POS Terminal. 

It is recommended that Idealpos be restarted after making this change to ensure that the setting has been applied. 

 

Further in-depth information about how this function affects Reports and the Cash Declaration are included in the 

User Guide. 

Go to: 

 

https://userguide.idealpos.com.au/#EFTPOS/Oolio%2520Pay%2520AUS%2520NZ/Oolio%2520Pay%2520AUS%2520NZ

.htm  

 

or 

 

https://userguide.idealpos.com.au/#EFTPOS/Oolio%20Pay%20Global/Oolio%20Pay%20Global.htm  

 

An example of how this function affects the End of Shift – Cash Declaration is included on the following page. 

 

  

https://userguide.idealpos.com.au/#EFTPOS/Oolio%2520Pay%2520AUS%2520NZ/Oolio%2520Pay%2520AUS%2520NZ.htm
https://userguide.idealpos.com.au/#EFTPOS/Oolio%2520Pay%2520AUS%2520NZ/Oolio%2520Pay%2520AUS%2520NZ.htm
https://userguide.idealpos.com.au/#EFTPOS/Oolio%20Pay%20Global/Oolio%20Pay%20Global.htm
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When performing an End of Shift, the Pinpad Surcharges will be separated from the EFTPOS Total on the Cash 

Declaration. 

Two examples have been included below. 

Example below left shows the Cash Declaration with the EFTPOS Totals and Pinpad Surcharges separated (function 

enabled by having a tender linked to the Pinpad Surcharge dropdown box). 

Example below right shows the Cash Declaration with the EFTPOS Totals and Pinpad Surcharges combined (function 

disabled by having the Pinpad Surcharge dropdown box set as blank with no surcharge tender linked). 

In both examples, a $10.00 EFTPOS sale was performed during the shift and a 5% Pinpad Surcharge ($0.50) was 

applied. 
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IP-6752 – PC EFTPOS NZ – Support for later printing of EFTPOS Receipts 

This function will include EFTPOS receipt data when a duplicate receipt is printed when using the PC EFTPOS NZ 

EFTPOS Integration in Idealpos. 

 

Duplicate Receipts can be printed using one of the following methods: 

 

RECEIPT button on the POS Screen 

The button can be added if required via Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen 

Layout > Buttons. 

Create a button as follows and press the button on the POS Screen to print a duplicate receipt. 

 

 
 

Journal History Enquiry – Back Office > Enquiry > Journal History > Select the Journal from the list > > Docket Print. 
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Fuel Console  

IP-6585 – Enabler Embedded Fuel Console Integration 

This function introduces the ability to configure Idealpos with the Enabler Embedded Fuel Console Interface. 

This interface enables Idealpos to connect to an Enabler Fuel Console system to connect to and communicate with the 

Fuel Pumps. 

As the configuration of this integration is outside the scope of the Update History Document, please refer to the 

Enabler Embedded page in the User Guide for further information on how to configure this integration with Idealpos. 

The topic can be found by going to the User Guide (https://userguide.idealpos.com.au) then from the Table of 

Contents, select Fuel Console > Enabler Embedded. 

Note that this integration will require the Enabler module to be enabled in the Idealpos Licence Gateway. 

Contact Idealpos or your Idealpos Reseller for more information. 

 

The below screenshot shows the Enabler Embedded interface at the top of the Idealpos POS Screen which is used to 

authorise Fuel Pumps and select fuel sales for payment. 

 

 
  

https://userguide.idealpos.com.au/
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Kiosk 

IP-6647 – Kiosk – Estimated Wait Time Function 

This function introduces the ability to display an estimated wait time at the top of the Kiosk screen. 

When consumers use the Kiosk, they will see the estimated wait time at the top of the Kiosk screen so that they know 

how long they can expect to wait before their order will be ready. 

The wait time that appears will need to be manually set by a Clerk via a standard Idealpos POS Terminal that’s 

networked with the Kiosk Terminal(s). 

 

To configure and use this function, go to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen tab > Locate a blank button and configure the Estimated Wait Time button as follows: 

 

Function: Kiosk Function 

Kiosk Function: Estimated Wait Time 

 

 
 

Save the button and close the POS Screen Layout window. 
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Go to:  

POS Screen > Click on the POS Screen tab where the button was saved > Press the “Estimated Wait Time” button. 

 

The POS Screen will display the Estimated Wait Time window which can be used to set the wait time.  

Using the on-screen numeric keypad, enter the Estimated Wait Time in minutes > Press “OK” to set the wait time. 

 

Notes –  

Entering a value of 0 or 00 will clear any Estimated Wait Time that has been previously set. 

A maximum Estimated Wait Time of 99 minutes can be set. 

 

 
 

Note – If the Kiosk is currently in use when the Estimated Wait Time is set or changed, the newly set Estimated Wait 

Time will appear for the next Kiosk sale.  

If the Kiosk isn’t currently in use (Kiosk is showing the Kiosk Home Screen welcome image), the Estimated Wait Time 

will appear after the Home Screen Image is closed. 

If the Kiosk is restarted while the Estimated Wait Time has been set, it will be retained so that upon starting the Kiosk, 

the Estimated Wait Time will be displayed as it was prior to restarting the Kiosk. 
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The Kiosk will show the Estimated Wait Time on the top-left corner of the Kiosk screen. 
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IP-6767 – Kiosk – Option to Display Stock Notes 

This function introduces the ability to display Stock Notes on the Kiosk screen when a Stock Item is being added to the 

sale. 

This function is useful for giving customers additional information about the item they’re about to purchase, such as 

ingredients included in the item or any other information. 

 

To configure and use this function, go to: Back Office > Setup > POS Terminals > Modify. 

Select a Kiosk Terminal > Modify > Display/Kiosk > Enable “Show Stock Notes”. 
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Add Stock Notes to the required Stock Items. 

Go to: Back Office > File > Stock Control > Stock Items > Select Stock Item > Modify > Advanced > Stock Notes. 

Enter the required Stock Item Notes into the Stock Notes field > Save. 

 

 
 

When the customer presses on the Stock Item on the Kiosk screen, they will see the Stock Notes displayed at the top 

of the screen, as per the example shown on the following page. 
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Order Numbers 

IP-6708 – Force Order Number on specific Department sales only 

This function introduces the ability to configure Idealpos so that a sequential Order Number is forced on specific 

Department sales. 

When a Stock Item from a specific Department is sold, an Order Number will be forced and applied to the sale 

automatically. 

 

To configure this function, go to: 

Back Office > Setup > Yes/No Options > Search: “Force Order” 

Enable the Yes/No Option “Force Order Number on Specific Departments” 

 

 
 

Each Department that requires the Order Number to be forced will need to be enabled. 

 

Go to: Back Office > File > Sales > Departments > Modify Department > Enable “Force Order Number”. 

Repeat this for each Department that requires Force Order Number. 
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The Order Number range will need to be set for each POS Terminal. 

 

Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Miscellaneous Settings. 

In the Show Order/to field, enter a range. 

It should be noted that when configuring multiple POS Terminals, each POS Terminal may benefit from having unique 

Order Number range to distinguish the Order Numbers that are issued between POS Terminals (if the same Order 

Number range is used across all POS Terminals, overlapping Order Numbers may be issued between POS Terminals 

which may lead to confusion when handling Customer’s orders). 
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The function is ready for use. 

When one or more Stock Items are added to the sale from the Departments that have the Force Order Number option 

enabled, an Order Number will be forced. 

 

Add Items to the sale: 
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After pressing the ENTER button to go to the Tender screen, the Forced Order Number is displayed at the top of the 

POS Screen. 

 

 
 

The Forced Order Number will be displayed on the Kitchen Dockets and Customer Receipt. 
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POS Terminals 

IP-6666 – User-Defined Options – Function to Copy to Other Terminals 

This function introduces the ability to Copy POS Terminal User-Defined Options to Other Terminals. 

To use this function, go to: Back Office > Setup > POS Terminals > Modify > POS Settings > User-Defined Options. 

Select a User-Defined Option and press the “Copy to All Terminals” button. 

 

 
 

A prompt is displayed with the selected User-Defined Option. 

Press “Yes” to copy the setting to all POS Terminals. 
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IP-6709 – Support for Override Tender Surcharge Amounts by POS (User-Defined) 

This function introduces the ability to override the Tender Surcharge Amounts by POS via a User-Defined Option. 

As Tender Surcharges are set globally and affect all POS Terminals, there may be instances where specific POS 

Terminals need to have the Tender Surcharge amount overridden with a different value. 

The User-Defined option outlined below will override the Tender Surcharge that is configured for any given Tender in 

Back Office > Setup > Function Descriptors > Modify > Surcharge. 

 

To configure this function, go to:  

Back Office > Setup > POS Terminals > Select the POS Terminal which requires the Tender Surcharge Amount to be 

overridden > Modify > POS Settings > User-Defined Options. 

Create the following User-Defined Option: 

 

• Description: TENDERxxOVERRIDESURCHARGE 

• Setting: New Surcharge Amount Here 

 

In the Description above, replace xx with the Tender that is being overridden. 

If overriding Tender 2 with a new Tender Surcharge of 5, then create the option as follows. 

 

• Description: TENDER2OVERRIDESURCHARGE 

• Setting: 5 
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Important points to note when using this function: 

• The Override Tender Surcharge User-Defined Option will use whichever Surcharge Type is currently configured 

for the Tender that is being overridden. 

E.g. If Tender 2 is configured with a “%” Type Surcharge (in Back Office > Setup > Function Descriptors > 

Tender 2), then this User-Defined Option will also use a “%” Type Surcharge with the overridden amount 

entered in the User-Defined Option. 

The below screenshot shows the Surcharge Type (% or $) that will be inherited by the User-Defined Option. 

 

 
 

• It is possible to create as many User-Defined Options as required (e.g. to override the Tender Surcharge for 

multiple Tenders). 

 

• If required, it is possible to override the Tender Surcharge amount with a 0 value using this User-Defined 

Option which will effectively disable the Surcharge for the Tender. 
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When the Surcharge has been configured as per the User Defined Option outlined above, it will be applied when the 

selected Tender is used in a sale. 
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Room Interface 

IP-6684 – Newbook Interface – Option to search Rooms by PosIdentifier 

This function introduces the ability to search rooms by POS Identifier when using the Newbook Interface. 

To configure this function, go to: Back Office > Setup > Global Options > Interfaces > Rooms. 

Set the Room Search by to “POS Identifier”. 

This will enable rooms to be searched by POS Identifier. 
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Scheduled Price Changes 

IP-6711 – Scheduled Price Changes 

This function introduces the ability to create Scheduled Price Changes that enable the Sell Prices of Stock Items to be 

changed automatically on a specified date and time. 

This is done via the creation of Scheduled Price Change batches which will contain the Stock Items that will have their 

Sell Prices changed. 

A user can create as many Scheduled Price Change batches as required. 

To use this function, go to: Back Office > File > Sales > Scheduled Price Changes. 

 

The main Scheduled Price Changes window will be displayed which contains the following options: 

• Modify – Modifies the currently selected Scheduled Price Change Schedule. 

• Add – Adds a new Scheduled Price Change Schedule. 

• Delete – Deletes the currently selected Price Change Schedule. 

• Copy – Creates a copy of the currently selected Price Change Schedule. 

• Run Schedule – Runs the currently selected Price Change Schedule. 

• Labels – Generates Labels for the currently selected Price Change Schedule. 

 

• Expired – Displays Scheduled Price Change Schedules that have expired. Expired Schedules include any 

Schedule that has a date and time prior to now. 
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To add a new schedule, press the “Add” button on the main Scheduled Prices Changes window. 

 

 
 

A new window will appear which will enable a Scheduled Price Change to be created. 

The options available in the Add Scheduled Price Change window are outlined in further detail on the following page. 
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• Schedule Description: Enter a name for the Schedule. This is simply a description used to identify the 

Schedule. 

• Run Schedule at: This is the date and time when the Schedule will run. 

• From POS: This is the POS Terminal from which the schedule will be run from. 

Note – For the Schedule to run, the POS Terminals must be turned on at the date and time specified in the 

“Run Schedule at” field. 

• Print Labels: If Labels are required for items that are having their Sell Prices changed, enable this option and 

select the default Label Style to use.  

The labels for all Stock Items with Sell Price Changes will be printed automatically from the POS Terminal that 

is selected in the “from POS” field when the Scheduled Price Change runs at the time set in the Run Schedule 

at. The Labels will be printed using the Price Level that has been chosen within the label format. 

If there are no label styles available in the dropdown box, they can be created by going to: Back Office > 

Utilities > Labels, choose the desired options for the Label Format, then next to the “Save Format As” button, 

enter a description for the label format, then press “Save Format As”. The saved format will be available when 

enabling the Print Labels option for the Scheduled Price Changes. 

• Delete Schedule after x Days: This option specifies whether the Schedule will be deleted and if so, how many 

days it will be deleted after the schedule has run.  

 

 
 

• Price Levels button: This button can be used to choose which Price Levels are going to be updated.  
By enabling Price Levels with this button, the Price Levels will be displayed in the Scheduled Price Changes 
Stock Items grid below. 
The button also enables the Cost Price Type to be selected (e.g. Standard Cost, Average Cost, Last Cost). 
The selected Cost Price Type will be shown in the Scheduled Price Changes Stock Item grid. 
After the desired options have been selected, press the “Apply” button. 
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To manually set New Sell Prices for Stock Items, search for the item in the Stock Items grid and enter a new Sell Price 
in the New Price field for the desired Price Level. 
Items can be searched via the column headers in the grid and new prices can be set via the New Price fields as 
shown below. 
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To use the Price Calculator to set new Sell Prices…  
Filter the Stock Items grid in the Scheduled Price Changes window to show the Stock Items that require their Sell 
Prices to be changed. 
Note that the Price Calculator will set a new Sell Price for all the Stock Items that are currently visible in the grid. 
Therefore, if all Stock Items are displayed and there’s no filter set, then the Price Calculator will set a New Sell Price 
for all Stock Items that are shown in the grid. 
If only some items are shown in the grid (by entering search terms via the column headers), then only those 
filtered/visible items will have their New Sell Prices set via the Price Calculator. 
 
To demonstrate this function, the grid has been filtered to only show Stock Items which have 1.25L in the 
Description and linked to the Soft Drink Department in the example below. 
When the required items have been filtered, press the “Price Calculator” button on the top-left corner of the 
window which will trigger the Price Calculator options to appear below. 
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• Update Prices In: This dropdown box is used to select which Price Level will be updated by the Price 
Calculator. Any calculated prices will be entered into the New Price field for the selected Price Level and 
those prices will be applied when the Scheduled Price Change is run either automatically at the specified 
date/time or manually via the “Run Schedule” button. 

• Base Calculation on: This dropdown box is used to select which Price Level the calculation will be based on 
and contains the following options - Price Levels 1 to 12, Price Levels 1 to 12 with “-new” appended onto the 
end, Standard Cost, Average Cost, Last Cost, Clear Prices. 
Selecting a Price Level 1 to 12 refers to the current Sell Price in the selected Price Level. 
Selecting a Price Level 1 to 12 with the “-new” text appended onto the end refers to the New Price that has 
been entered for that Price Level. 
Selecting Standard, Average or Last Cost will base the calculation on the selected Cost Type. 
Clear Prices will clear the New Prices for the Price Level that has been selected in the “Update Prices In” 
dropdown box above. 

• Calculation Method: Options available are Percent +/-, Dollar +/- or Profit Margin. 

• Calculation Method value: This field is shown below the Calculation Method field and is used for entering 
the Calculation amount that will be used with the Calculation Method when calculating New Sell Prices. 

• Round: This dropdown box controls what type of rounding will be used on the final calculated Sell Price. The 
available options are -Up nearest 5c, Up nearest 10c, Up nearest 50c, Down nearest 5c, Down nearest 10c, 
Down nearest 50c.  

• Update Price Level #: This button will show the Price Level that has been selected in the “Update Prices In” 
option and pressing this button will trigger the Price Level to be updated using the selected calculation 
options. 

 
Each of the above options are shown below: 
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To demonstrate this function, the Price Calculator has been set as per the following screenshot. 
Update Prices In: STANDARD (Price Level 1) 
Base calculation on: STANDARD (Price Level 1) 
Calculation method: Percent +/- 
Calculation value: 10 
Round: Up nearest 5c 
 
Press the “Update Price Level 1 (STANDARD)” button to update the New Price for that Price Level using the options 
in the Price Calculator. 
 

 
 
A confirmation prompt is displayed. 
Press “Yes” to continue. 
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After pressing “Yes”, another prompt is displayed that will confirm that the prices have been updated. 
 

 
 
The New Prices for the Stock Items will be populated. 
Note that as mentioned above, only the items that were filtered will have their New Prices updated. 
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When the Description and Department Filters are cleared, all the Stock Items will be displayed.  
Only the items that were filtered at the time the Price Calculator was used will have their New Prices updated.  
Any other Stock Items that weren’t included in the filter when the Price Calculator was used will retain their 
previously entered New Prices or blank New Prices. 
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The “Send to Report” button can be used to produce a report of all the items. 
Note that the “Send to Report” function will include all the Stock Items that are currently displayed in the grid. 
Therefore, if wanting to report only on the Stock Items that have Price Changes, ensure that the “Price Changes 
Only” button is pressed prior to pressing the “Send to Report” button. 
Also note that the report will allow a maximum of three Price Levels to be displayed. 
If more than three Price Levels have been selected via the Price Levels button (on the top-right corner of the 
Scheduled Price Changes window), then the following prompt will be displayed when pressing the “Send to Report” 
button. In the prompt, select the three Price Levels to display on the Report, then press the “View” button. 
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The Scheduled Prices Changes are displayed in a report format which can be printed, emailed, saved to PDF or 
exported. 
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Stock Items 

IP-6687 – Stock Item Attributes – Adding new Attribute will auto assign to current Stock Item 

This function introduces the ability to auto assign a new attribute to the current Stock Item. 

When modifying a Stock Item and assigning Attributes to the Stock Item, when a new Attribute is created on-the-fly, 

the new Attribute will be automatically assigned to the Stock Item. 

If multiple Attributes are added on-the-fly, the last Attribute that is created will be assigned to the Stock Item. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items > Select a Stock Item > Modify. 

On the bottom-right corner of the Modify Stock Item window, select an Attribute Type from the first drop-down box. 

Then press the “+” button to create a new Attribute on-the-fly. 

 

 
 

Enter a Description for the new Attribute, then press the “+” button to add the new Attribute. 
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Close the Add Attribute window. 

The new Attribute will be assigned to the Stock Item. 

In the example below, the “1.5L Bottle” Attribute has been automatically assigned to the Stock Item after it was created 

on-the-fly. 

 

 
 

In previous builds of Idealpos, the newly created Attribute would have to be manually selected from the drop-down 

list after being created on-the-fly. 

 

If multiple Attributes are created on-the-fly, the last Attribute that is created will be assigned to the Stock Item. 

If a different Attribute is required, select the required Attribute from the drop-down menu. 
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IP-6705 – Stock Items – Option to not automatically update Sell Price on Metcash downloads 

This function introduces the ability to not automatically update Sell Prices on Metcash downloads. 

This functionality is enabled at the Stock Item level by going to: 

Back Office > File > Stock Control > Stock Items > Select a Stock Item > Modify. 

In the Other tab, enable the checkbox “Don’t Update Sell Price on Host Downloads” 

 

 
 

When a Metcash Host is downloaded, the Sell Price of the Stock Item will not be modified. 
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Utilities 

IP-6638 – Clear Data – Option to Clear Data for all Sites other than the current one 

This function introduces the ability to Clear Data for all other Sites except for the current one from where the data is 

being cleared. 

This is an advanced function and should be used with caution by advanced users. 

 

To use this function, go to: Back Office > Utilities > Clear Data. 

Set the Selection Criteria as required (e.g. Date Range and enable checkboxes for data that needs to be cleared). 

Enable the checkbox “Keep Data for This Site (Site Name)”. 

This option will clear data for all other sites except for the current site from which the action is being performed. 

Note – When using the “Select All” button, all checkboxes will be selected in the Clear History section except for “Keep 

Data for This Site”. If the option “Keep Data for This Site Only” is required, then it will need to be manually enabled by 

clicking into the checkbox to enable it. 

 

 
 

When ready to clear data, select the “Proceed” option on the top-left corner of the window. 
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Yes/No Options 

IP-6572 – Yes/No Option – Automatically Prompt to Round Up for Donation functionality 

This function introduces the ability to configure Idealpos to display a prompt to round up the final sale amount on the 

POS Screen to the next whole dollar. The rounded amount will be paid to the pre-configured Receive Account 

function. 

This functionality can be used to donate funds to a charity or to Tips, depending on what the venue desires. 

 

To configure this function, go to: Back Office > Setup > Yes/No Options > Search: “donation”. 

Enable the Yes/No Option “Automatically Prompt to Round Up for Donation”. 

 

 
 

After the Yes/No Option has been enabled, each Tender will need to have the “Allow Overcharging To Tips” option 

enabled. 

 

Go to: Back Office > Setup > Function Descriptors. 

Modify each of the Tenders that are in use by selecting the Tender > Modify > Enable “Allow Overcharging To Tips”. 
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The Receive Account Function that the Rounded amount will be donated to is set in the EFTPOS Settings for each POS 

Terminal. 

 

Go to: Back Office > Setup > POS Terminals > Select a Terminal > Modify > EFTPOS Settings > Overcharging to Tips. 

Select the desired Receive Account function for the rounded-up amounts to be donated to. 
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If a new Receive Account function is required, this can be configured by going to: 

Back Office > Setup > Function Descriptors > Locate an unused Received Account Function. 

There are four available Received Account functions that can be used. 

Unused Received Account Functions will be labelled as “RA #”, where # will be a number between 1 and 4. 

Select the next unused Received Account function, modify it and update the Description as required. 

Press “Save” on the top-left corner to save the change. 

The newly named Received Account Function can be selected in the EFTPOS Settings as outlined above. 
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After the above steps have been completed, the function is ready for use. 

When the total amount of a sale is a rounded dollar amount (e.g. $10.00, $2.00, $20.00, etc.), the prompt will not be 

displayed. 

When the total amount of a sale is not a rounded dollar amount (e.g. $10.20, $11.85, etc.) and the ENTER button is 

pressed, the POS Screen will display a round up prompt as follows. 
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Pressing “No” will continue to the Tender screen without rounding up. 

Pressing “Yes” will round up the sale to $11.00 and then continue to the Tender screen. 

An additional line will be added to the sale with the automatically calculated donation amount which triggered the 

sale to be rounded to the next whole dollar amount. 

 

 
 

The customer receipt will also show the donation amount. 
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The Donations will be listed in the Financial Report (Back Office > Reports > Financial > Financial Report). 

 

If the donations will need to be paid out to a charity, a Paid Out Function will need to be assigned as “Payout 

Donations” and a POS Screen button will also need to be created so that the donations can be paid out. 

 

Go to: Back Office > Setup > Function Descriptors. 

Locate the next unused PAID OUT function, modify it and change the description to “PAYOUT DONATIONS”. 

Unused PAID OUT functions will be listed as “PO #”, where # is the number of the PAID OUT function. 
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A Payout Donations button can then be created on the POS Screen by going to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen tab where the Payout Donations button is required (e.g. Admin) > Locate a blank unused button 

and configure as follows: 

 

 
 

Donations can then be paid out to a charity as follows: 

From the POS Screen, enter the amount to payout to the charity > Press the “Payout Donations” button. 

The amount will be displayed as a line in the sale window of the POS Screen. 

Press the ENTER button to go to the Tender screen. 

Then select a tender and the entered amount will be paid out. 

 

This function is also outlined in the User Guide. 

Go to: https://userguide.idealpos.com.au and select “Automatically Prompt to Round Up for Donation” from the Table 

of Contents on the left-hand side of the User Guide. 

  

https://userguide.idealpos.com.au/
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IP-6692 – Yes/No Option – Indirect Items can be linked to Suppliers for Report Filters 

This function introduces the ability to link Indirect Stock Items to Suppliers so that those Indirect Items can be 

reported on in Idealpos Reports when the report is Grouped or Filtered by Supplier. 

Note that this function is not used for the purpose of ordering Indirect Items from Suppliers. 

It is purely for reporting purposes only. 

 

To configure and use this function, go to:  

Back Office > Setup > Yes/No Options > Search “Indirect Items”.  

Enable the Yes/No Option “Indirect Items can be linked to Suppliers for Report Filters”. 

 

 
 

To assist with identifying Indirect Stock Items in the Stock Items grid, the Indirect File Field may need to be enabled in 

the Stock Items grid. 

This can be done by going to: Back Office > Setup > Users. 

Select the User > Modify > ensure that the Indirect option is enabled under File Fields > Stock Items. 
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The final step to setting up this function is to link the Indirect Stock Items to Suppliers. 

Go to: Back Office > File > Stock Control > Stock Items. 

The Indirect search field can be used to filter the list of Stock Items in the grid. 

In the Indirect field, enter “y”. 

The Stock Items grid will be filtered to only show Indirect Stock Items. 

 

 
 

The required Stock Items can then be modified and linked to their respective Suppliers. 

Select a Stock Item > Modify. 
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In the Default Supplier field, press the “>” button to link the Indirect Stock Item to a Supplier. 
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Then select a Supplier from the dropdown box > Save. 

 

 
 

Repeat the above process for each Indirect Stock Item that needs to be linked to a Supplier. 

  



    Update History 
Return to top 

Idealpos 9 Build 5 - Update History Page 58 of 59 

 

When running a Report, the Indirect Stock Items will now be associated with their respective Suppliers. 

Go to: Back Office > Reports > Sales > Stock Item Sales. 

Select “Supplier” from the Group Field section, then press “View” to run the Stock Item Sales Report. 
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The Stock Item Sales Report will group Indirect Stock Items under their respective Suppliers. 

 

 


